Tidal Fish Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
246 Posts
Discussion Starter · #1 ·
Sorry that I'm not real knowledgable on the new E-techs, but I haven't got this one figgured out yet----several times during the first hour of running the alarm comes on and says no oil (the oil tank is full) and drops back to "safe" mode. I shut it down, start it up and pump on the fast idle thingamachig a few times and take off again. It might do this 5 or 6 times during the first hour of operation that day, but then straighten up and run great for the rest of the day.......What am I doing wrong or whats up with that...btw 30XDS oil...is the weather to cold for that oil?

BTW its a 2005, I have no owners manual or anything---I got a left over from a Lund employee deal...it was almost as good as holding a gun to the dealers head,,,brand new and never mounted:clap:
 

·
Banned
Joined
·
165 Posts
Sorry that I'm not real knowledgable on the new E-techs, but I haven't got this one figgured out yet----several times during the first hour of running the alarm comes on and says no oil (the oil tank is full) and drops back to "safe" mode. I shut it down, start it up and pump on the fast idle thingamachig a few times and take off again. It might do this 5 or 6 times during the first hour of operation that day, but then straighten up and run great for the rest of the day.......What am I doing wrong or whats up with that...btw 30XDS oil...is the weather to cold for that oil?

BTW its a 2005, I have no owners manual or anything---I got a left over from a Lund employee deal...it was almost as good as holding a gun to the dealers head,,,brand new and never mounted:clap:
I just bought the 75 Hp ETEC and mine is programed for XD 100. I asked the dealer whats the difference and he said the the local climate is to cold to run anything else..So you want to check and see what the EMM module on the motor is programed for..When I went in to pick mine up he had it hooked to a computer with a bunch of wires running from it..They have to program what oil is used and the prop size and all kinds of other crazy stuff. Also pushing the fast idle to many times can put the the motor in winter storage mode..I have the owners manual and it explains how to fog the motor with the XD 100 oil by using the the fast idle control.. Intercoastal marine is where I got mine..Give them a call and ask for Terry...410-335-0458 Good folks to deal with..They are off of Bowleys Quarters RD
 

·
Registered
Joined
·
26 Posts
just purchased a 90 e-tec and agree w/ river crab the motor is programed to automatically set the high idle until warm is over than auto-idle down. If you are advancing the throttle before starting you are telling the motor to winterize, it is that easy!
 

·
Registered
Joined
·
500 Posts
Can't help you on the motor, but if you know of any women over the age of 18 that fit the criteria, let me know!!!
C'mon Cam2, look at his board name, no chance he knows any women over the age of 14 that fit that criteria. (Unless you don't count kin :eek2: ) WVBowhunter, sorry but I couldn't resist the easy WV joke.
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #7 ·
LOL on the gals clark and cam---hey you aint the cam I use to know several years ago that fished with Donnie Goins (Quadman) are ya....I heard that guy fell off the face of the earth lol
 

·
Registered
Joined
·
18 Posts
My 90 did the same thing, result, replaced engine. There seems to be a design flaw on the lower cylinder on some of them, according to e-tec rep. They said it was nothing but a design flaw. They replaced the power head, 1 more low oil warning, then everything has been fine. I still love the engine. My opinion is that it is a great engine, but as with new technology, some glitches might show up as the engines get out there.
 

·
Registered
Joined
·
629 Posts
1) Get an owner's manual ... I think you can download one from BRP's website and READ it.
2) If your motor is under warranty (they are guaranteed for three years), use a dealer for what you think is a warranty issue ... don't mess with it yourself unless you're absolutely sure you know what you're doing.
3) Stop using the **** oil, have a dealer make sure the EMM is programmed for XD100 oil and don't use anything else. Other oils promote carbon build up and other bad things for Etechs.

Good luck with a good motor.

Jim
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #10 ·
Well I had the engine programmed for XD 30 (regular 2 cycle vs the synthetic)...I downloaded the manual for a 2006 (not a 2005) and have been using that...the only oil that has been in it has been Evinrude/Johnson---almost 2 gals now.
 

·
Banned
Joined
·
165 Posts
Well I had the engine programmed for XD 30 (regular 2 cycle vs the synthetic)...I downloaded the manual for a 2006 (not a 2005) and have been using that...the only oil that has been in it has been Evinrude/Johnson---almost 2 gals now.
They didnt recommend the XD 100..I was just going by what the dealer told me about the climate here in MD..Good luck with it.
 
1 - 11 of 11 Posts
Top