Tidal Fish Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
I have a problem with my 97 Yamaha 25 2 stroke pull start. I got it running on Sat and headed out and the motor died. A squeeze on the new fuel bulb pumped it back up and it started up again with no choke. Started running and it cut off again. I rowed back to my dock and changed the plugs (the ones that came out looked OK). When I squeezed the bulb I could here it making a swooshing sound from the pick-up tube in the 6 gal portable tank. I pulled the pick-up tube (4 screws) and when I lifted it out the clear tube fell off the connection and into the tank. After Dad fished it out (the only thing caught all day:eek2:) I put a hose clamp on it and put it back together. It appeared that the OEM metthod of holding the tube and in tank stariner on was some white adhesive that was not completely 360 degrees around the inside of the pick-up tube which has a very loose fit to the connector block. Now when I squeeze the bulb it goes flat and will not pump fuel. Any one have any comments or suggestions? Thanks in advance.
 

·
Registered
Joined
·
334 Posts
Could be that the fuel bulb and hose are defective. My OMC fuel bulb went bad and wouldn't hold a prime. Bulb would also collapse and starve the engine of fuel. Got a new hose and bulb assembly and no more problem. Don't know how that connection in you tank might affect your fuel supply but that might also be causing a fuel starving.
 

·
Registered
Joined
·
170 Posts
fuel bulb

had similar prob. had bought replacment hose and bulb ,not oem looked the samebut had problems. put on oem solveded prob, 2 cts worth tinman 23 parker wa
 
1 - 3 of 3 Posts
Top