Tidal Fish Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
10,547 Posts
Discussion Starter · #1 ·
While trolling last Saturday we got hung on the bottom and ended up losing a nice umbrella rig and lots of braided line . After breaking it off , my 320GTI level wind feature won't work . Before I tear it apart has anyone here had this problem and do you know how to fix it ? I know it can't be that hard and if I do need parts I have access to them . I'd like to have this reel ready for seabass fishing next week . Thanks ahead of time , Mike .
 

·
Registered
Joined
·
2,446 Posts
First question, how old is your reel? If it's 20+ years old there was a design change due to problems with the levelwind and you will have to upgrade the whole levelwind system including worm gear, gear shield and bearings...How do you know if it's the old style? If it is a plastic line guide you have the old version and need the updated package...if it's the newer version it will have a metal line guide...

Check to see if the line guide itself is bent and/or is caught on the line guide post (highy unlikely)...

Next check to see if your reel frame is twisted due to the strain from the high line tension...sometimes the frame will twist and throw things "out of whack" causing the levelwind to bind...

Next check your pawl which is located at the bottom of the line guide behind the big screw...take it out and see if it is bent and/or worn...replace it if necessary... most times when the line guide doesn't work is because the pawl is worn...

try these and see if it helps...if not it may be an internal problem with a gear or bearing...

Give me a call if you have any questions, I'll be glad to help if I can...443-848-1074
 

·
Registered
Joined
·
10,547 Posts
Discussion Starter · #9 ·
First question, how old is your reel? If it's 20+ years old there was a design change due to problems with the levelwind and you will have to upgrade the whole levelwind system including worm gear, gear shield and bearings...How do you know if it's the old style? If it is a plastic line guide you have the old version and need the updated package...if it's the newer version it will have a metal line guide...

Check to see if the line guide itself is bent and/or is caught on the line guide post (highy unlikely)...

Next check to see if your reel frame is twisted due to the strain from the high line tension...sometimes the frame will twist and throw things "out of whack" causing the levelwind to bind...

Next check your pawl which is located at the bottom of the line guide behind the big screw...take it out and see if it is bent and/or worn...replace it if necessary... most times when the line guide doesn't work is because the pawl is worn...

try these and see if it helps...if not it may be an internal problem with a gear or bearing...

Give me a call if you have any questions, I'll be glad to help if I can...443-848-1074
Thanks . The reel was purchased in 2000 . I will give you a call .:thumbup:
 

·
Premium Member
Joined
·
26,271 Posts
If you are handy - take it apart and see if the tiny lock nut on the level wind shaft (on the handle side) came off.I've had two do that.I put them back on with Loc Tite.You need to be careful how tight you go- too tight and it won't turn.

The sugguestion on the stripped gear is also very good advice.Once apart- you'll see how it works.It is nothing hard to understand.Be sure to lube the gears while it is apart.
 
1 - 13 of 13 Posts
Top