Tidal Fish Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
659 Posts
Discussion Starter #1
Need info as to if I have a problem or not. My boat has the 5.0 Mercruiser I/O 5.0. I have noticed that there is corrosion on the Elbows that connect the Exhaust Manifolds to the Exhaust. These elbows are isolated from any grounding because of the rubber boots that are used to connect them to the Exhaust Manifold and the exhaust. All the corrosion is under the paint. All paint pulled off by hand. Scraped both elbows with same results. Is this normal and do I need to take off and clean + repaint or leave as is. Any help is greatly appreciated.
Thanks
Bubba[angel][angel]
 

·
Registered
Joined
·
1,514 Posts
I think this is pretty standard after time of use. You have heat and salt water which is about as good of a combination for rust there is. It could be a sign that they are beging to deteriorate but they could still have years of use. If they are 4 or 5 years old and never get flushed out you may want to get them checked out. My first boat had a Volvo and if you took the cap off the heat exchange and could put your hand over the top and could keep the water in it was ok. If you could not hold the water in do to back presure it was a sign they were deteriorating. I would guess every engin is different but usualy the temp will slowly start to creep up as they start to deteriorate it usually does not happen over night. I would ask you mech and just keep an eye on you temp readings. You can also have them beed blasted to clean them out which i know Culpepper Radiator in Portsmouth use to beed blast and I think they still would. They can also inspect them but for either they have to be removed. Hope this may help some I'm by no means an expert its just from past experiences.
 
1 - 3 of 3 Posts
Top