Tidal Fish Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter · #1 ·
I have a 50 hp 2 stroke Merc. outboard on an 18' tracker grizzly. I was scouting some duck hunting areas that had a lot of sea grass that keep getting hung up on the lower unit, I'd stop the motor and remove it. While heading back to the ramp my alarm sounded, so I stopped the engine and of course, more grass. Cleared it and fired the motor back up, the alarm sounded for about 10 seconds then went off.

Is there anything I should do or check to make sure all is well? I flushed out the motor when I got home, everything seemed fine.

P.S. this is my first year owning a boat.

Thanks...Jeff
 

·
Registered
Joined
·
1,315 Posts
Sounds like a overheat alarm. While flushing make sure that the motor is "peeing" a ggod stream of waterand if it persists you might need to replace your impeller. If you have any additional questions feel free to call (757) 321-0693 or bmail me

Mike
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #3 ·
Thanks for the reply Mike.
I had been keep an eye on the water coming out of the pee tube when I was in the sea grass but once we got to the channel I stopped checking. O'well, live and learn.

The stream was fine when I flushed the engine, I will keep an eye on it though:eek2:

Thanks...Jeff
 

·
Registered
Joined
·
1,247 Posts
Impellor should be replaced every couple of years regardless. Just pulled mine yesterday and it was pretty stiff although intact. The vanes should be flexible. Hot horn is solid tone, oil is intermitent beeps. If you don't know when impellor was replaced, do it. It's an easy job. But your circumstances are clearly blocked intake.
 
1 - 4 of 4 Posts
Top