Tidal Fish Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter · #1 ·
Was getting ready to head to the launch ramp this morning and ran into a snag. When I first pressed the trim up button on the controller;;er nothing happened. Released and pressed again and the motor started to rise. Stopped half way up to arrange fuel line and that's as far as I got.

Motor would not go up using the controller or the cowl switch. However, it goes down just fine.

It's a 2005 Merc XR-6 150 HP. Jiggled all the wires near the cowl switch and open, lubed all the connections in the area as well. Trim / tilt fluid is full.

If anyone has ever experienced or heard of a trim / tilt that will go down but not up L'd love to know the cause.
 

·
Registered
Joined
·
3,679 Posts
The two switches control one or two relays. The fact that both switches don't work and the fact that the motor does operate in the down direction makes me think that it is a relay issue.
 

·
Registered
Joined
·
236 Posts
Discussion Starter · #7 ·
Thx all.

Bonna order a pair of relays and see if that's the problem. They're cheap enough that I won't be terribly upset if it's something else.
 

·
Registered
Joined
·
236 Posts
Discussion Starter · #8 ·
Was getting ready to head to the launch ramp this morning and ran into a snag. When I first pressed the trim up button on the controller;;er nothing happened. Released and pressed again and the motor started to rise. Stopped half way up to arrange fuel line and that's as far as I got.

Motor would not go up using the controller or the cowl switch. However, it goes down just fine.

It's a 2005 Merc XR-6 150 HP. Jiggled all the wires near the cowl switch and open, lubed all the connections in the area as well. Trim / tilt fluid is full.

If anyone has ever experienced or heard of a trim / tilt that will go down but not up L'd love to know the cause.
FYI - installed new relay and trim goes up - trim goes down. Done and done.

Thx again
 
1 - 10 of 10 Posts
Top