Tidal Fish Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
699 Posts
Discussion Starter · #1 ·
I have a brand new TLD 25 that i just tried to use on Wednesday of last week and it would not allow me to drop the gear back into free spool? I have two others and have never had a lick of problems with them. Haven't consulted the manual yet, I know, I know, but I thought I would post here and see if anyone has had a similar problem and can tell me what is wrong and how to fix. Going out tommorow so would like to get rectified this evening.... Thanks!!
 

·
Registered
Joined
·
1,612 Posts
Are you sure its just not a little stiff getting back into free spool? I have noticed on some before that they seem to almost click when they are new when backing all the way off.
 

·
Premium Member
Joined
·
4,888 Posts
Are you pushing in the freespool button to allow it to go back into freespool? It's possible the lever was installed in the wrong postition.
 

·
Registered
Joined
·
573 Posts
How much drag pressure do you have on it?

TLDs sometimes have issues with free spool when there is a lot of drag pressure on there (and I mean A LOT...especially with a 25). Try moving the lever back to free spool, then back off the drag dial slightly and see if that helps.

Also, remember when you are setting your drags to put the reel in free spool before turning the drag knob.

Let us know what you figure out.

j
 

·
Registered
Joined
·
699 Posts
Discussion Starter · #8 ·
just got to working on it....

and the lever won't go ANYWHERE!! HELP!!! I DON'T want to tear this thing down tonight...
 

·
Registered
Joined
·
573 Posts
will the drag knob turn at all? Back that sucker off a good bit and see what happens.



IF that doesnt turn, take it back to where you got it.

or call queens creek and ask them. they repair shimanos all day long, so they would probably have a good idea.
 
1 - 9 of 9 Posts
Top