Tidal Fish Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
699 Posts
Discussion Starter · #1 ·
--------------------------------------------------------------------------------

I have a brand new TLD 25 that i just tried to use on Wednesday of last week and it would not allow me to drop the gear back into free spool? I have two others and have never had a lick of problems with them. Haven't consulted the manual yet, I know, I know, but I thought I would post here and see if anyone has had a similar problem and can tell me what is wrong and how to fix. Going out tommorow so would like to get rectified this evening.... Thanks!!
 

·
Registered
Joined
·
699 Posts
Discussion Starter · #4 ·
what's happening Barry....

nah... not since I've seen you I don't think. Went rockfishing last Wednesday and did ok and going again tommorow. Did kill a nice buck though opening day which you can see on the chesapeake hunting forum on here. Had an invite to go for the Bluefin tommorow but gotta take company guys out rockfishing instead. Which means Mike will probably put a giant BFT in the boat!! We need to hook up and do some fishing, or drinking, or something!

Thanks to all who replied. Gonna go home now and see if I can figure out the problem. Somebody said take it apart and see what's wrong, not that hard. Yeah... well those kind of projects always end up bad for me. But I'll post whatever I find out. I kinda wanted that TLD rig in the rockfish spread tommorow.
 

·
Premium Member
Joined
·
4,888 Posts
Those things are super simple to take apart. My guess is the handle was installed int he wrong position if it's new. Otherwise it could be hanging up on the freespool button. BTW i got two for sale 90$ apeice and one has an ALantani handle.
 

·
Premium Member
Joined
·
4,888 Posts
Drip some lube (LSA if you are a gun guy) on this button and work it with your finger until it springs in and out nice and smooth. This should help. If not play with the drag
adjustment knob and make sure it isn;t too loose or tight.
 

·
Registered
Joined
·
699 Posts
Discussion Starter · #8 ·
thanks for the input guys!!

gonna try everything now!! Mike, this is one of those reels that I bought new a while back and never got a rod for it till couple of weeks ago. Can't even remember where I bought it! I'm hoping greentop and that I can find the receipt. But it could be more than a year ago. hope not!! Mike, good luck on the BFT tommorow, if we get our main radio working I will try a hail call late to see if I catch you coming in but we will probably be WAY to far away. I will hit your cell. I feel it! Your gonna get a giant! Or at least fight one!!
 

·
Premium Member
Joined
·
1,574 Posts
Those things are super simple to take apart. My guess is the handle was installed int he wrong position if it's new. Otherwise it could be hanging up on the freespool button. BTW i got two for sale 90$ apeice and one has an ALantani handle.
If you don't mind me asking, why are you selling the reels? Upgrading perhaps?

-JB
 

·
Registered
Joined
·
699 Posts
Discussion Starter · #10 ·
thanks for the help everyone....

i broke down and read the manual, reread your advice, took it apart sans alcohol;-), and got it working in about 20 minutes this weekend. Ready to hang a rockfish if we can locate any before the water gets too cold.
 

·
Premium Member
Joined
·
4,888 Posts
If you don't mind me asking, why are you selling the reels? Upgrading perhaps?

-JB
I've got a bunch of them. For awhile it was a hobby to buy and service them according to the Alan Tani method, but how many Tld's does one man need. The Tf'er who bought these two is getting reels that are way better than they came from the factory. I plan on using the money for a couple of gold reels for sharking. I need something a little more substantial for the tourny winners.
 

·
Premium Member
Joined
·
4,888 Posts
i broke down and read the manual, reread your advice, took it apart sans alcohol;-), and got it working in about 20 minutes this weekend. Ready to hang a rockfish if we can locate any before the water gets too cold.
So what was wrong?
 

·
Registered
Joined
·
699 Posts
Discussion Starter · #13 ·
just as a couple people pointed out

the lever had basically just been assembled in the wrong position. When I first tried to fix it I was quite inebriated and after taking the lever off was tightening the drag cap or screw without having the reel in free spool. Duhhh. But yeah, I guess someone at the factory was in a hurry that day. Once I soberly pulled it apart and reassembeled according to the manual, with drag in free spool, it was fixed. Now, wish it would stop blowing so we could go fishing!!
 
1 - 16 of 16 Posts
Top