Tidal Fish Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter #1
All the lights on my trailer work except the driver's side blinker.

I changed the bulbs and still the blinker is not working.

Any ideas why?
 

·
Registered
Joined
·
272 Posts
Discussion Starter #2
Forgot to mention that the ground wires/connections on both the tow vehicle and trailer are brand new and in good shape.

Also, I used a 12-volt tester to check the tow vehicle wiring and it all seems to be working fine.
 

·
Registered
Joined
·
861 Posts
Make sure that the ground at that light is good. Most lights bolt to the trailer and use the frame as a ground, rust occurs under the mounting causing a bad ground. If you have a separate ground wire going to each light (not likely) check that.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #5
thought I'd reply to myself one more time in case anyone out there is having similar trouble with their trailer.

I just got back from Uhaul. Hooked my truck up to 2 different trailers and sure enough, once I hooked to them the driver's side blinker did not work on either of the two trailers.

So now I know my problem is with my truck wiring.

Next step for me is to buy a T-connector and give that a try....will keep you posted.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #9
New T Connector (truck wire harness) did the trick....thanks.

This is the 3rd T connector I've had to put on my Ford in the 5 years I've had it.
 
1 - 9 of 9 Posts
Top