Tidal Fish Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
943 Posts
Discussion Starter · #1 ·
Year 2000
Model SX 250 OX66 Saltwater seris
H.P. 250

Boat get up and runs, If we push it hard (4900rpm's)
it stops in it's tracks.
It will re-Fire and Cruise , if you take it easy.

it's not the Suction side sreen on the Pump housing, nor the Fuel filter on the Motor.


any Ideas?
Les
 

·
Registered
Joined
·
8,994 Posts
Fuel Pump/s!!Have a Buddy that had the same problem/same Motor,Run Her up,then it felt like someone would just turn the key off.Started right up,would idle fine,run Her up and the same thing.Think it was the High Pressure pump if I remember correctly. [Mike]
 

·
Registered
Joined
·
943 Posts
Discussion Starter · #6 ·
Well it's not the screen in the VST, not the High pressure fuel pump and not the 3 fuel pumps,
running out of options.

I'm going to try, pumping the bulb while running.

Les
 

·
Registered
Joined
·
943 Posts
Discussion Starter · #9 ·
Not sure how see a screen in the tank?
It's just a welded tube sticking out.

What Check Valve?

If the vent is clogged wouldn't ,opening the Fill cap , check it?

Les
 

·
Registered
Joined
·
111 Posts
You need to hook up a pressure guage between the low pressure& high pressure pumps to see if low is staying at 3-5 psi,then apressure guage hooked to the valve on top of the vst to make sure the high pressure is 45-50 psi otherwise you will be going in cicles to find the problem,if you continue to run the engine as it is you will burn it up!
 

·
Registered
Joined
·
943 Posts
Discussion Starter · #11 ·
Thanks, I'll buy another pressure gauge tommorrow , when the stores open.
Kinda hard to check at High Rpm's?

Les
 

·
Registered
Joined
·
11 Posts
When is the last time you replaced the impellar? It may be overheating and droping out the rpms . This is a safety measure most all engines now have. Plugs fouled?
 

·
Registered
Joined
·
943 Posts
Discussion Starter · #15 ·
O.K. running in a big trash can.
Fuel pressure 40psi at idle 50psi reving the throtle.
Vaccum 3in.

Maybe it's not a fuel problem after all?

Les
 

·
Registered
Joined
·
111 Posts
Pressure needs to be checked with the boat in the water at the speed it is loosing rpms,low pressure on feed line to vst,high pressure on top of vst,running it without a load is not really checking the problem
 

·
Registered
Joined
·
943 Posts
Discussion Starter · #17 ·
The factory says the fuel pressure should be a constant 35psi.
Maybe the pressure regulator is bad?
I removed the Vaccuum? line from the pressure regulator and the boat ran the same.
Maybe it is the pressure regulator?

Les
 

·
Registered
Joined
·
111 Posts
Les,What was the pressure reading betwwen the low pressure pumps to the vst reading while you were out running your boat in the water and was the vst maintaining 35psi while running at 48-4900 rpm
 
1 - 20 of 24 Posts
Top